Cloud Provider Outages Delaying Object Reporting

Incident Report for Stairwell

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 22:57 UTC

Identified

The issue has been identified, we are awaiting a fix from Google.
Posted Jun 12, 2025 - 19:26 UTC

Investigating

We are currently investigating an issue with Google Cloud and other providers that limits the ability of users to login to the Stairwell app and upload files.
Posted Jun 12, 2025 - 19:25 UTC
This incident affected: Stairwell App, File Intake, and API.