Disruption with Stairwell services

Incident Report for Stairwell

Resolved

Mitigations have been confirmed working and changes have been paused.
Posted Jul 29, 2025 - 20:40 UTC

Monitoring

We have deployed mitigations and are working to verify.
Posted Jul 29, 2025 - 20:36 UTC

Investigating

We are currently investigating this issue.
Posted Jul 29, 2025 - 20:25 UTC
This incident affected: Stairwell App.